auto stoneskin my elemental on glance

Scripts and support for your favorite MUD client.
watashi420
Sojourner
Posts: 28
Joined: Sat Dec 15, 2001 6:01 am
Location: Maine
Contact:

auto stoneskin my elemental on glance

Postby watashi420 » Mon Nov 09, 2009 4:05 am

i was hoping someone could please help me create a trigger to cast stone skin on my air elemental if i glance at him and he isnt stoned. Thanks for any help you can give

Bizibobble
Kegor
Sojourner
Posts: 665
Joined: Wed Feb 28, 2001 6:01 am
Location: St. Cloud, MN
Contact:

Re: auto stoneskin my elemental on glance

Postby Kegor » Wed Nov 11, 2009 12:40 am

Code: Select all

#CLASS {SHAMAN|STONE}
#ALIAS gloff {#ECHO -= Auto-Stone: OFF =-;#T- ASTONE;#T- GLANCE2;#T+ GLANCE1}
#ALIAS glon {#ECHO -= Auto-Stone: ON =-;#T+ ASTONE;#T+ GLANCE2;#T- GLANCE1}
#CLASS 0
#CLASS {SHAMAN|STONE|GLANCE2}
#ALIAS gl {#T+ ASTONE;glance}
#CLASS 0
#CLASS {SHAMAN|STONE|GLANCE1}
#ALIAS gl {glance}
#CLASS 0
#CLASS {SHAMAN|STONE|ASTONE}
#TRIGGER {{his|he|her|she|its}(%s)body seems to be made of stone!$} {#VAR STONE {NOCAST}}
#TRIGGER {$} {#IF (@STONE != "NOCAST") {c 'stone' @PERSON};#VAR STONE {NOCAST};#WAIT 2000;#T- ASTONE}
#TRIGGER {{You don't see that here.|Glance at whom?}$} {#T- ASTONE}
#TRIGGER {&%wPERSON {is in an excellent condition|has a few scratches|has some small wounds and bruises|has quite a few wounds|has some big nasty wounds and scratches|looks pretty hurt|is in awful condition}. ~(*~)$} {#VAR STONE {}}
#CLASS 0


This is the one I made for my shaman. When turned on and you glance any player or mob and they are not stoned, you will cast it on them. So be careful to only 'look' at mobs you do not want to stone. This should work as is for elementals, let me know if it doesn't and have you trouble getting it to work.
Last edited by Kegor on Fri Nov 13, 2009 11:26 pm, edited 1 time in total.
watashi420
Sojourner
Posts: 28
Joined: Sat Dec 15, 2001 6:01 am
Location: Maine
Contact:

Re: auto stoneskin my elemental on glance

Postby watashi420 » Wed Nov 11, 2009 2:53 am

okay i tried it and typed glon and it doesnt do anything for me =(
Kegor
Sojourner
Posts: 665
Joined: Wed Feb 28, 2001 6:01 am
Location: St. Cloud, MN
Contact:

Re: auto stoneskin my elemental on glance

Postby Kegor » Wed Nov 11, 2009 11:32 pm

Hmm. Check your general parsing settings by clicking on View -> Preferences -> General Parsing and make sure that all boxes are checked except for Show Triggers, Allow <> for expand, Allow VBScript, and Allow JScript.

If this is not your problem then try importing again and check to make sure everything imported properly and that the main class folder is enabled.
watashi420
Sojourner
Posts: 28
Joined: Sat Dec 15, 2001 6:01 am
Location: Maine
Contact:

Re: auto stoneskin my elemental on glance

Postby watashi420 » Thu Nov 12, 2009 4:11 am

Hm, i don't know what to say. i checked all those things, fixed what was checked in pasring options, re copied it in, and they are enabled. i type glon and it says the echo, but then nothing happens still. Oh well, thanks anyway kegor, i appreciate it, i must be doing something wrong. ><

Bizibobble
Kegor
Sojourner
Posts: 665
Joined: Wed Feb 28, 2001 6:01 am
Location: St. Cloud, MN
Contact:

Re: auto stoneskin my elemental on glance

Postby Kegor » Fri Nov 13, 2009 12:56 am

You know, I bet you have a glance alias somewhere else that is messing it up. You need to find it and delete it because it will override any other alias of the same name. There is one that can be turned off and on in the class GLANCE1 for when this trigger is turned off.

If that's not the problem, the class folder GLANCE1 should be turned off and GLANCE2 enabled when this trigger is active. If you have both enabled it won't work also.
watashi420
Sojourner
Posts: 28
Joined: Sat Dec 15, 2001 6:01 am
Location: Maine
Contact:

Re: auto stoneskin my elemental on glance

Postby watashi420 » Fri Nov 13, 2009 3:03 pm

hm, you were right, i have (had) an alias that was gl=glance. i deleted it, and restarted zmud, deleted your trigger again, and re-pasted it in, and i still cant seem to get it to work. :( oh well, again, i appreciate all the help. i must still be doing something wrong

bizibobble
Kegor
Sojourner
Posts: 665
Joined: Wed Feb 28, 2001 6:01 am
Location: St. Cloud, MN
Contact:

Re: auto stoneskin my elemental on glance

Postby Kegor » Fri Nov 13, 2009 11:25 pm

Doh. It wasn't working because of the new size changes that appears next to a player or mobs name. Sorry man didn't even think to test it out to see if mine worked until now, heh.

Trigger has been edited above to correct the problem.
watashi420
Sojourner
Posts: 28
Joined: Sat Dec 15, 2001 6:01 am
Location: Maine
Contact:

Re: auto stoneskin my elemental on glance

Postby watashi420 » Mon Nov 16, 2009 3:09 pm

Perfect! Ah, thank you so much Kegor. It works great, exactly what i needed. Thanks again for your perseverance!

Bizibobble

*edit* Now, about 5 hours later, i am trying to get the trigger to work on my desktop (that i use more often, and had been having the trigger work earlier on my laptop) and i cant get it to work ... gah, i feel dumb. i made sure all the options are correct, i have deleted all the old triggers and the gl=glance alias, i see that the different classes are enabled when i type glon and gloff and see the echo, it just doesnt do anything again... sigh, im just frusterated by it worked no problem on my laptop this morning ... i don't know what to do. . . either way i'm probably doing something wrong, oh well.

*edit* okay now i had been trying to start over, maybe because i have a set of triggers that are broken or something, so i backed up my torilmud.org info in zmud, and deleted it, made a new one., and when i try to use the trigger it gives me errors ... sigh bdouble blast now, lol

*edit* okay, now i had to uninstall zmud, and delete all the files it leaves behind to get it to stop erroring. now when i paste the trigger into a completely fresh zmud 7.21, it looks like it should work, i see the echo, and when i glance at myself it just types "c 'stone' " and i get "Who should the spell be cast upon?" repeating. . . this has became quite the headache, lol. just to add in the fact that my ethernet drivers had to be fixed on my laptop earlier today has made this day full of fun repairing . . . i dunno what to do now, and all my aliass are gone hehe. oh well

*edit* okay, stratch that, now its back to just not doing anything (once i deletect it, restarted zmud, and then repasted it in) i see the triggers, they enable/disable in the correct way , glon and gloff have echos, just nothing when i glance at stuff... i am so confused lol . i did change the options too

*edit* now, the morning after, as im on my laptop, i see that i have the options set to different things, so im going to compair them to the desktop and see if that fixes it
Kegor
Sojourner
Posts: 665
Joined: Wed Feb 28, 2001 6:01 am
Location: St. Cloud, MN
Contact:

Re: auto stoneskin my elemental on glance

Postby Kegor » Wed Nov 18, 2009 4:42 am

Zmud errors? Boggle.

This definately sounds like incorrect parsing options, or some other options within ZMUD setup. Good plan to recheck all of your ZMUD options from the machine that is working and verify them to the one that is not. That should do the trick.

This is just a standard trigger set that captures and manipulates variables. Nothing fancy or corrupted about it. Honest!
watashi420
Sojourner
Posts: 28
Joined: Sat Dec 15, 2001 6:01 am
Location: Maine
Contact:

Re: auto stoneskin my elemental on glance

Postby watashi420 » Wed Nov 18, 2009 5:31 pm

Yeah , im going to get to the bottom of it, thanks again for all the help! It works on my laptop , so theres nothing wrong on your end, i just have to double check everything. Thanks again kegor

Bizibobble
Pril
Sojourner
Posts: 1834
Joined: Sat May 11, 2002 5:01 am

Re: auto stoneskin my elemental on glance

Postby Pril » Wed Nov 18, 2009 7:11 pm

Kegor's trigger:

Code: Select all

#TRIGGER {{his|he|her|she|its}(%s)body seems to be made of stone!$} {order russian mail order bride and download viruses)


:)
watashi420
Sojourner
Posts: 28
Joined: Sat Dec 15, 2001 6:01 am
Location: Maine
Contact:

Re: auto stoneskin my elemental on glance

Postby watashi420 » Thu Nov 19, 2009 1:15 am

Okay, just had to change my options to what i had on my laptop and it started to work after i deleted it and repasted it again. Thanks again Kegor.

Bizibobble

Return to “MUD Client Help”

Who is online

Users browsing this forum: No registered users and 2 guests