Mudlet Script v011rc2 (4/22/2018)

Scripts and support for your favorite MUD client.
Nyyrazzilyss
Sojourner
Posts: 29
Joined: Tue May 19, 2015 6:30 am

Mudlet Script v011rc2 (4/22/2018)

Postby Nyyrazzilyss » Sun Apr 08, 2018 6:33 pm

I've posted a Toril script for Mudlet 3.x.x+ 3.8.1+ recommended http://www.mudlet.org If it's a prior version of Mudlet, it won't work.

Latest stable script version posted (4/22/2018) is 011rc2 (removed link, old version)

DOWNLOADING: Click on the above link to download the script package.

Once installed, the script can be bypassed and anything sent direct to the mud by typing the first letter of the command as a capital letter.

Image Image
Image Image

There are 3 ways to install. As a new installation, an in-place update of an existing profile, or creating a new profile with all the data from the previous profile. Choose the appropriate.

Use the package manager. If the module manager is used, it will unpack every time and not save any script changes.

New installation:

1) Create a new toril profile (torilmud.com 9999), and connect to it. Important: Don't log in to the mud (yet).
2) Use the mudlet package manager icon to import the NyyLIB mpackage file you downloaded.
3) Log in to the mud.

Type '@help' for client related instructions.
Type '@set' for a list of settings/options.

Creating and updating a new profile from a pre-existing profile.

1) Use the @backup command to make a backup of your datafiles into another folder. Note: This doesn't backup any changes you might have made to the script itself.
2) Create a new toril profile (torilmud.com 9999), and connect to it. Don't log in to the mud (yet).
3) Use the mudlet package manager icon to import the NyyLIB mpackage file you downloaded to the new profile.
4) Log in to the mud
5) Use the @backup command again to restore the datafiles to the new profile. Don't touch/delete the old profile.
6) Exit and restart mudlet.
7) After logging in, type '@map update' to update older maps with the map included with the newer version.

In-place updating of an existing profile:

1) Prior to updating, use the #backup command to make a backup of your datafiles into another folder. Note: This doesn't backup any changes you might have made to the script itself.
2) Select the package manager icon inside mudlet, and uninstall the previous package installed. ** NOTE ** - The previous package will be prefixed with NyyLIB - Don't remove anything else!
3) Import the new NyyLIB mpackage file you downloaded.
4) Exit and restart mudlet.
5) After logging in, type '#map update' to update older maps with the map included with the newer version.

Map progress is saved when updating. Type '@map update' to add new included areas to the loaded map image without losing previous progress.

Known Issues:

The mud prompt must be of a format '< 818h/818H 913p/913P 120v/120V P: sit >'

The script won't run properly if the installation path includes a '$' or non-latin characters as part of the path.

-- 011rc2

-- Katumi database update - 4/15/18
-- Map updated: full size 317 areas 45460 rooms
-- bugfixes
-- added warrior
-- @set border now accepts colorname, hex value
-- autoroller: status display reformatted, added anti timeout
-- @fol mobname - follows an unfollowable mob
-- @set font - font to use for buttons
-- @set colbuttonoff - use to set the button text colour when off
-- @set colbuttonon - use to set the button text colour when on
-- @set condensed echosend - enabled displays everything sent to mud (for debug purposes)
-- @set maperror false - disable map room error suppression
-- @cd changes fleemode to 'lich'
-- autoassist is disabled by default after joining a group
-- buttons are now generated realtime from a table
-- url's in the chat window are now clickable
-- name in chat window now shows timestamp on mouseover
-- captures to the chat windows have been reformatted to remove redundant information
-- Added pause to train on low hp/movement, thanks @Afu for idea
-- Ranger, Paladin, and Blackguard refactored
-- added blackguard
-- spellcasting added to paladin
-- direction added to @cd
-- An error message will be displayed if mapper has likely gone out of sync
-- A helpfile entry was submitted! Thanks @Areh
Last edited by Nyyrazzilyss on Wed Mar 27, 2019 3:41 am, edited 14 times in total.
Vaarkus
Sojourner
Posts: 7
Joined: Fri Apr 06, 2018 9:14 pm

Re: Mudlet Script v011rc2 (4/8/2018)

Postby Vaarkus » Sun Apr 08, 2018 7:23 pm

Hello. I was trying to install your scripts and Im having issues. I completely scrubbed my computer of all mudlet related files and did a clean install then followd the first set of instruction. When I try to log in after i install the module and close then restart and the unpacking window pops is successfull then I type in my log in name and i get the following message:

[NyyLIB requires restart after installation.] I hope its just me doing something wrong. Any help is appreciated and thank you for the time it took you to read this. Have a great day!

Edit: I sort of figured out whats wrong. If I set my Torilmud profile to auto connect then I log in just fine, but if I type i get the above error of [NyyLIB requires restart after installation.]
and it seems that it doesnt matter what I type. After loging in I couldnt select a character or quit or anything. Anyway I hope this helps.
Last edited by Vaarkus on Sun Apr 08, 2018 7:31 pm, edited 2 times in total.
Nyyrazzilyss
Sojourner
Posts: 29
Joined: Tue May 19, 2015 6:30 am

Re: Mudlet Script v011rc2 (4/8/2018)

Postby Nyyrazzilyss » Sun Apr 08, 2018 7:28 pm

Vaarkus wrote:EDIT: please disregard, I got it to work somehow. Thank you.


Hello. I was trying to install your scripts and Im having issues. I completely scrubbed my computer of all mudlet related files and did a clean install then followd the first set of instruction. When I try to log in after i install the module and close then restart and the unpacking window pops is successfull then I type in my log in name and i get the following message:

[NyyLIB requires restart after installation.] I hope its just me doing something wrong. Any help is appreciated and thank you for the time it took you to read this. Have a great day!


I'll take a look, but easy solution on that is if you get a message 'NyyLIB requires restart after installation' (you shouldn't with anything after about 3.4) just restart mudlet
Vaarkus
Sojourner
Posts: 7
Joined: Fri Apr 06, 2018 9:14 pm

Re: Mudlet Script v011rc2 (4/8/2018)

Postby Vaarkus » Sun Apr 08, 2018 7:32 pm

I did restart, several times. The problem is that i get the error message [NyyLIB requires restart after installation.] every time i type in a character and hit enter. If I set my login to be automatic I can get into the character select screen but anything I manual type in returns the above error.
Vaarkus
Sojourner
Posts: 7
Joined: Fri Apr 06, 2018 9:14 pm

Re: Mudlet Script v011rc2 (4/8/2018)

Postby Vaarkus » Sun Apr 08, 2018 7:44 pm

maybe this will help? It also does it with your previous module.

Characters:
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
1) Ranit Level 1 Cleric (Human)
2) Obiy Level 9 Cleric (Human)
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Type the # or name of a character above to login or choose an action below.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
(N)ew character | (L)ink character | (U)nlink character | (R)eorder
(E)nter description | (D)elete character | (C)hange password | (Q)uit
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Your choice:
2
[NyyLIB requires restart after installation.]
ranit
[NyyLIB requires restart after installation.]
obiy
[NyyLIB requires restart after installation.]
N
[NyyLIB requires restart after installation.]
D
[NyyLIB requires restart after installation.]
Q
[NyyLIB requires restart after installation.]
help
[NyyLIB requires restart after installation.]
im stuck
[NyyLIB requires restart after installation.]
Nyyrazzilyss
Sojourner
Posts: 29
Joined: Tue May 19, 2015 6:30 am

Re: Mudlet Script v011rc2 (4/8/2018)

Postby Nyyrazzilyss » Sun Apr 08, 2018 7:53 pm

Top left corner, what version of mudlet does it show?

Example: Mudlet 3.8.0

I would guess that you're seeing that after restarting mudlet (not to mention seeing it in the first place) you're likely to have other issues.

Typing:

lua disableAlias("restart")

Would clear that particular message, but i'm more concerned that you're seeing it in the first place.
Last edited by Nyyrazzilyss on Sun Apr 08, 2018 7:56 pm, edited 1 time in total.
Vaarkus
Sojourner
Posts: 7
Joined: Fri Apr 06, 2018 9:14 pm

Re: Mudlet Script v011rc2 (4/8/2018)

Postby Vaarkus » Sun Apr 08, 2018 7:54 pm

I am so very very sorry. I was trying to use the Module manager and not the package manager. Thank you for responding. Have a wonderfull day!

Return to “MUD Client Help”

Who is online

Users browsing this forum: No registered users and 2 guests