Problems with weapon fumbling trigger

Scripts and support for your favorite MUD client.
Rahl
Sojourner
Posts: 25
Joined: Fri Apr 27, 2001 5:01 am
Location: West Plains, MO USA
Contact:

Problems with weapon fumbling trigger

Postby Rahl » Wed May 23, 2001 1:46 am

Okay, I'm having a little trouble with my trigger I use to retrieve my weapon after I fumble it. The trigger works fine for most weapons but I just got this one and it does not work with it.

Here's the trig: You swing _really_ badly, sending your * (%w) flying!

The weapon is called a double-bladed duergar mithril battle-axe

My last weapon was a dwarven battleaxe (or something to that effect) and the trigger worked fine for that. With my new weapon, my trigger wont even go off.



------------------
Rahl -- Guardian of pink bunnies and anything fluffy
cherzra
Sojourner
Posts: 1868
Joined: Fri Jan 26, 2001 6:01 am
Location: Holland

Postby cherzra » Wed May 23, 2001 7:26 am

The trigger works, it's just the weapon that should have been given another keyword. Find out what the keyword is and make an if statement. I don't have zmud at hand but it would be something like this

if (%1=="a double-bladed duergar mithril") {get mithril;wield mithril}
else
{get %2;wield %2}
Gindipple
Sojourner
Posts: 676
Joined: Fri Jan 26, 2001 6:01 am
Location: O' Fallon, MO. USA
Contact:

Postby Gindipple » Wed May 23, 2001 8:27 am

See 3rd post this thread http://www.sojourn3.org/ubb/Forum4/HTML/000058.html

all you need is one keyword that is in the fling text and works to get it and that trigger will do the job.
Rahl
Sojourner
Posts: 25
Joined: Fri Apr 27, 2001 5:01 am
Location: West Plains, MO USA
Contact:

Postby Rahl » Wed May 23, 2001 11:58 am

I just dont understand why the trigger won't even go off. and I've tried to manually get the last keyword (get battle-axe) and it works fine that way.....
oh, Gindipple the URL didnt work for me.
Gindipple
Sojourner
Posts: 676
Joined: Fri Jan 26, 2001 6:01 am
Location: O' Fallon, MO. USA
Contact:

Postby Gindipple » Wed May 23, 2001 5:58 pm

The URL didn't work?!?
Or do you mean what's at the url?
If that the case get with me online I'll get your trigger working.
Valeos/Dorac
Sojourner
Posts: 35
Joined: Thu Mar 29, 2001 6:01 am
Location: Canada Eh!

Postby Valeos/Dorac » Wed May 23, 2001 8:29 pm

trig: You swing _really_ badly, sending your (*) (%w) flying!
command: get %2;wield %2

that works fine for me
Moctar
Sojourner
Posts: 6
Joined: Sat May 12, 2001 5:01 am
Location: Iowa
Contact:

Postby Moctar » Fri May 25, 2001 7:36 pm

I have the same problem, zmud doesn't like storing hyphenated words into variables.
gurzog
Sojourner
Posts: 62
Joined: Wed Feb 14, 2001 6:01 am

Postby gurzog » Sun May 27, 2001 4:04 am

Your trig is probably not working because battle-axe is not one of the keywords for the axe. Guess maybe mithril and axe are the keywords for it. So you'll have to do like Cherzra said and put the #if in there.

"The weapon is called a double-bladed duergar mithril battle-axe"
It's grabbing the last word which is battle-axe.
Gindipple
Sojourner
Posts: 676
Joined: Fri Jan 26, 2001 6:01 am
Location: O' Fallon, MO. USA
Contact:

Postby Gindipple » Sun May 27, 2001 5:06 am

hyphenated words work in 4.62, I'd be shocked if they didn't in futer versions

Return to “MUD Client Help”

Who is online

Users browsing this forum: No registered users and 3 guests